Problem
If you get an error message similar to that one: USB device "XXX" already in use by another process
Cause
An antivirus software or other 'security software' is blocking the access to the interface. You can find some information here on how to disable USB scanning in various antivirus products.
Resolution
Temporarily deactivate any software that may interfere with the USB connection (e.g. antivirus, firewall). Additionally, look yourself for the software that has opened a USB device:
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Find the USB device in the device manager, the easiest way is to plug and unplug it.
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In the properties note "Object name of the physical device" (e.g. \Device\000001ad)
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Call Find / Find Handle or DLL with the Process Explorer and search for this object name.
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See also this: ThinkPad software might block the KNX/USB interface , Citrix Workspace app blocks the licensing dongle, Logitech LampArray translation service might block the KNX/USB interface and Alienware Clien Management Service
Case 1: Logi LampArray Service:
It has been identified that a KNX/USB interface might become unavailable for use because of a software service called "Logi LampArray Service". To resolve this issue, you need to disable it and try again.
Case 2: Citrix Workspace app blocks the licensing dongle:
Problem
The licensing dongle is not recognized by ETS although it's recognized by the computer.
Cause
The ‘Citrix Workspace App’ (used for accessing Citrix Terminal Servers) with the version published on the 30th January 2023, offers the option to enable a feature called ‘AppProtection’, which prevents Keyloggers and Screen captures during Citrix Sessions.
When this software is installed with this option enabled, then our licensing dongles are no longer recognized by ETS.
Resolution
- Uninstall the ‘Citrix Workspace App’ and try connecting the licensing dongle after a reboot.
- If you still need the ‘Citrix Workspace App’ you can re-install it, but keep the option for the "AppProtection" unchecked.
Case 3: ThinkPad TrackPoint Keyboard II Software:
It has been identified that a KNX/USB interface might become unavailable for use because of a software driver called "ThinkPad TrackPoint Keyboard II Software". This driver causes a problem because the HID driver for this device is opened by some processes and the USB interface is no longer available for ETS. To resolve this issue, you need to terminate three processes that are associated with the driver:
The three processes that need to be terminated are:
- Osd.exe
- SetSpeed.exe
- HScrollFun.exe
These processes are part of the Lenovo "External Trackpoint Keyboard driver" which is included in the latest Atos CAT client package as a preinstalled component.
Case 4: Alienware Clien Management Service
The service (Alienware Client Management Service) that must absolutely be deactivated and not only stopped otherwise the problem persists in the background.