Problema
Se riceve un messaggio di errore simile a questo: Dispositivo USB "XXX" già in uso da un altro processo
Causa
Un software antivirus o altro 'software di sicurezza' bloccano l’accesso all’interfaccia. Può trovare alcune informazioni qui su come disattivare la scansione USB in vari prodotti antivirus.
Soluzione
Disattivare temporaneamente qualsiasi software che possa interferire con la connessione USB (ad es. antivirus, firewall). Inoltre, cercate voi stressi il software che ha aperto un dispositivo USB:
-
-
Trova il dispositivo USB nel gestore dispositivi, il modo più semplice è quello di collegarlo e scollegarlo.
-
Nella note proprietà "Nome oggetto del dispositivo fisico" (es. \Device\000001ad)
-
Chiama Find / Find Handle o DLL con Process Explorer e cercalo per il suo nome oggetto.
-
Veda anche questo: Il software ThinkPad potrebbe bloccare l'interfaccia KNX/USB, l'applicazione Citrix Workspace blocca il dongle di licenza, il servizio di traduzione Logitech LampArray potrebbe bloccare l'interfaccia KNX/USB e il servizio di gestione di Alienware Clien.
Caso 1: Servizio Logi LampArray:
È stato identificato che un'interfaccia KNX/USB potrebbe diventare non disponibile per l'uso a causa di un servizio software chiamato "Logi LampArray Service". Per risolvere questo problema, deve disattivarlo e riprovare.
Caso 2: l'applicazione Citrix Workspace blocca il dongle di licenza:
Problema
Il dongle di licenza non è riconosciuto da ETS, anche se è riconosciuto dal computer.
Causa
L'applicazione 'Citrix Workspace App' (utilizzata per accedere a Citrix Terminal Server) con la versione pubblicata il 30 gennaio 2023, offre l'opzione di attivare una funzione chiamata 'AppProtection', che impedisce i Keylogger e le catture dello schermo durante le sessioni Citrix.
Quando questo software è installato con questa opzione abilitata, le nostre dongles di licenza non sono più riconosciute dall'ETS.
Soluzione
- Disinstalli 'Citrix Workspace App' e provi a collegare il dongle di licenza dopo un riavvio.
- Se ha ancora bisogno di 'Citrix Workspace App', può reinstallarla, ma mantenga deselezionata l'opzione 'AppProtection'.
Caso 3: Software ThinkPad TrackPoint Keyboard II:
È stato identificato che un'interfaccia KNX/USB potrebbe diventare non disponibile per l'uso a causa di un driver software chiamato "ThinkPad TrackPoint Keyboard II Software". Questo driver causa un problema perché il driver HID di questo dispositivo è aperto da alcuni processi e l'interfaccia USB non è più disponibile per ETS. Per risolvere questo problema, è necessario terminare tre processi che sono associati con il driver:
I tre processi che devono essere terminati sono:
- Osd.exe
- SetSpeed.exe
- HScrollFun.exe
Questi processi fanno parte del "driver di tastiera esterna Trackpoint" Lenovo che è incluso nell'ultimo pacchetto client Atos CAT come componente preinstallato.
Caso 4: Servizio di gestione dei clienti Alienware
Il servizio (Alienware Client Management Service) che deve assolutamente essere disattivato e non solo fermato, altrimenti il problema persiste in background.