Probleem
Als u een soortgelijke foutmelding krijgt als deze: USB-apparaat "XXX" al in gebruik door een ander proces
Oorzaak
Een antivirussoftware of andere 'veiligheidssoftware' blokkeert de toegang tot de interface. U kunt hier informatie vinden over hoe u USB-scannen in verschillende antivirusproducten kunt uitschakelen.
Oplossingen
Deactiveer tijdelijk alle software die de USB-verbinding kan verstoren (bv. antivirus, firewall). Kijk daarnaast zelf naar de software die een USB-apparaat heeft geopend:
-
-
Zoek het USB-apparaat in het apparaatbeheer; de eenvoudigste manier is om het te koppelen en te ontkoppelen.
-
In de eigenschappen "Objectnaam van het fysieke apparaat" (bijv. \Device\000001ad)
-
Roep Find / Find Handle of DLL aan met de Proces Explorer en zoek naar deze objectnaam.
-
Zie ook dit: ThinkPad-software blokkeert mogelijk de KNX/USB-interface, Citrix Workspace-app blokkeert mogelijk de licentie-dongle, Logitech LampArray-vertaalservice blokkeert mogelijk de KNX/USB-interface en Alienware Client Management Service
Geval 1: Logi LampArray Service:
Er is vastgesteld dat een KNX/USB interface mogelijk niet beschikbaar is voor gebruik vanwege een softwareservice met de naam "Logi LampArray Service". Om dit probleem op te lossen, moet u het uitschakelen en het opnieuw proberen.
Geval 2: Citrix Workspace app blokkeert de licentie dongle:
Probleem
De licentiedongle wordt niet herkend door ETS, hoewel hij wel wordt herkend door de computer.
Oorzaak
De 'Citrix Workspace App' (gebruikt voor toegang tot Citrix Terminal Servers) met de versie gepubliceerd op 30 januari 2023, biedt de optie om een functie genaamd 'AppProtection' in te schakelen, die Keyloggers en Screen Captures tijdens Citrix Sessies voorkomt.
Wanneer deze software is geïnstalleerd met deze optie ingeschakeld, worden onze licentiedongles niet langer herkend door ETS.
Oplossingen
- Verwijder de 'Citrix Workspace App' en probeer de licentie dongle aan te sluiten na een herstart.
- Als u de 'Citrix Workspace App' nog steeds nodig heeft, kunt u deze opnieuw installeren, maar laat de optie voor de "AppProtection" uitgevinkt.
Geval 3: ThinkPad TrackPoint Keyboard II Software:
Er is vastgesteld dat een KNX/USB-interface mogelijk niet meer beschikbaar is voor gebruik vanwege een softwarestuurprogramma genaamd "ThinkPad TrackPoint Keyboard II Software". Dit stuurprogramma veroorzaakt problemen omdat het HID-stuurprogramma voor dit apparaat door sommige processen wordt geopend en de USB-interface niet langer beschikbaar is voor ETS. Om dit probleem op te lossen, moet u drie processen beëindigen die aan het stuurprogramma zijn gekoppeld:
De drie processen die moeten worden beëindigd zijn:
- Osd.exe
- SetSpeed.exe
- HScrollFun.exe
Deze processen maken deel uit van de Lenovo "External Trackpoint Keyboard driver", die als vooraf geïnstalleerd onderdeel is opgenomen in het nieuwste Atos CAT-clientpakket.
Geval 4: Alienware Client Management Service
De service (Alienware Client Management Service) die absoluut moet worden gedeactiveerd en niet alleen gestopt, anders blijft het probleem op de achtergrond bestaan.