Error message:
ETS encountered a problem during communication for ETS licensing
Cause:
The error message occurs:
- when Windows forbids ETS to access the file. This is usually the case due to security policies. For example, incorrectly configured user access rights, etc.
- if the user, or someone else, has manually marked the file in question as read-only
- any kind of I/O error that causes the file to be inaccessible (for whatever reason). E.g. the user has mapped the file via Symlink to a network drive and that is currently inaccessible.
Solution:
The most promising approach is to ensure that the file is not marked as read-only.
- Locate the file under "%localappdata%\KNX\ETS6" (copy the content within the quotation marks into your Windows Explorer address).
- Right click on the file > Properties and ensure that the attribute 'Read-only' is unchecked.
or delete the file, so that it is created correctly again afterwards.
If this does not help, ensure that the Windows user profile, under which the ETS6 process is running has access rights to the file. Since also an antivirus software might interfere, it might help to temporarily deactivate it and try again.
Moreover, some good practices for cloud licensing issues:
- You have the latest ETS6 version installed
- Your internet connection is stable
1. To verify that you have the latest ETS6 version installed, you need to:
- Open ETS6
- Login with your MyKNX credentials
- Go to ‘Settings’

- There you will see which version you have, and you will be able to ‘Check for Updates'
- If an update is available, it is highly recommended to install it. After installing it, logout from ETS6 and close it.

2. Before you restart ETS6, make sure you have a stable internet connection, then:
- Open ETS6
- Login with your MyKNX credentials
- Select the license ETS6 proposes
- Click on ‘Activate’
- In the next step, you’ll see the message “Where shall the license be stored?”
- Select ‘Computer’ and activate your cloud session